Designing for Accessibility in Powerpoint
To follow is a list of the main steps that should be taken in ensuring PowerPoint accessibility:

1. Ensure good navigability:
e Use slide titles,
e Ensure proper reading order,
e Format your tables correctly,
e Format your charts correctly,
e Check your document outline

2. Ensure a positive and productive user experience:
e Embed your images with alternative text,
e Ensure decorative artifacts are treated correctly,
e Ensure sufficient foreground / background contrast
e Be colorblind aware,
e Treat typefaces correctly - font-size, color relationships,

The best time to address these issues is at the beginning of the design stage. Start by choosing a template
that works well to allow assessibility to begin with.

1. File > New->Blank Presentation - Design Tab.
2. Look at the various theme choices that appear below the main ribbon. Choose one that is not
too busy and has a bigger range of color squares paired with it.
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No. Too busy and not enough darks and Yes! Better contrast (lots of darks and
lights in terms of color choices in the lights) and bacgrounds are not too busy.

squares below the main panels.

2 The second set of themes shown above is suitable and can be customized to match various
branding guidelines or other themes.
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3. Select the theme design by clicking on it. Note the first slide appears in the navigation pane to
your left. Click on it to start editing it.

4. Select the View tab and then from the Masters View Group, choose, Slide Master
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5. Click on the colors menu .
6. Click on Customize Colors option at the bottom of this menu| e | and start adjusting

the colors in this pallete until you are satisfied. Keep your hyperlink color blue however. It is more
easily recognized as a link for the vision impaired.
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ht 2 -

individuals cannot distingquish between RG
and YB combinations when they are next to
each other spatially. Always use black or a very
dark shade of grey for your fonts. Use birght
reds sparingly and for decorative and
peripheral or decorative elements only.
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7. While you're still working in the Slide Master ribbon, let’s change the fonts that will populate your
slides. Click on the first slide in the navigation bar (The larger slide on top of the slide tree). In the
main pane, highlight the font, “Click to edit...” Right click on it, and change the font to Arial Black
and the font color to black. Change the subheadings below it to Arial Black as well and the color to
black. Let’s change the fields (dates, slide numbers, headers and footers) that will show up on your
slides as well.
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8. Back up in the Master Layout Goup. Click on the Slide Master tab again. biastes views

9. This window will pop up in your main pane. Untick Date, Slide Number, and Footer (unless you want
those fields to show up on all the slides in your presentaiton).

Master Layout ?

Placeholders
Text

Date

Slide number
Footer
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10. Now you’re ready to start building your slides. Click Close Master View

Close
Master View

Clase

11. At this point, you can start picking and choosing among slide layouts to format your presention. On
the home ribbon, from the Slides group, click on the the New Slide button and choose the “Blank”
style slide from the drop down menu.

12. Click on the slide icon that appears in the navigation pane to highlight it. Now put your cusor inside
the slide in the main pane, and insert a picture into the slide. Use the Insert tab to navigate to a
folder with an image in it. Click and place the image on your slide. Drag to resize the photo. For this
exercise, make it a large image.

13. Now continue to build your presentation, using the New Slide button to choose the formatting
layout for each new slide you make.



14. Once your presentaiton is built, there’s steps you can take to ensure its accessibility. Step one is to
run an Accessiblity Check. In the main ribbon, Click Review Tab = Check Accessibility.
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15. In a sidebar to the right, the accessibility checker will offer Inspection Results. These reports contain
two kinds of results — errors and warnings. The checker also gives easy instrucitons for fixing the
error. Scroll down below the report to where the report says Steps to Fix. Take the suggested steps
to fix the problem. As each error is fixed, it will disapear from the Errors List in the Inspection Results
Report.

Accessibility Ch... ~

Inspection Results
Errors

4 Missing alternative text
Picture 2 (Slide 2)
Explosion: 14 Paints 5 (Slid...
Flowchart: Surmming Juncti..

4 Table has no header row
Table & (Slide 4)

4 Missing slide title

Slide 2
Slide 4 / w

L Steps To Fix:

4 Hard-to-read text contrast 1, Right-click the object, then select
Table 6 Row 1 Cell 1 (Slide 4) Edit Alt Text,

2. If the object is meaningful, type a
Table & Row 1 Cell 2 (Slide 4) description of it in the text box on the
Tahle fi R 1 Cell 3 (Slide 41 Alt Text pane; otherwise, if the object

AR fanetal I foe i is purely decorative, select the
Decorative check box,
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16. Note in Slide 2, the results are indicating that the image is missing alternative text. Alternative text
provides screen readers with some description of the image or object which is then read aloud to its
user. In terms of user experience, alternative text can help the visually impaired to better
understand how the image relates to the broader context of the presentation over all.

Alt Text LAl

How would you describe this object and its
Fontext to someone who is blind?

1-2 sentences recommended)

Image is a lighthouse on the shore of Big
Ocean Bay. It is the only lighthouse
opened to the public|c;n Sundays.




17. Here are some more problems and easy fixes: busy background, low contrast text in the foreground.

Figure 1. Poor contrast, font too small, busy distractive background.

18. Check for contrast with a site like WebAim. Use the eyedropper tool and shoot to earn at least AA
status with your color choices. When you click on the foreground color swatch as it is ticked below, a
pop-up window with an eyedropper in the lower left corner will appear. Click on the eyedropper and
then click on your slide’s main font color. Next grab the eyedropper tool from the background
color’s pop-up. and use it to check your slide’s background color. The slide pictured above earned a
fail due to there being a low contrast ratio between the two.

Foreground Color / Background Color pd

#o95950 | memmmm | [#CA2r1A | mmm—— m Shoot for a
Light Light .
1gntness 1ghtness much hlgher
el contrast ratio!
Normal Fext
WCAG AA: Fail
WCAG AAA: | Fail
Large Text
WCAG AA: Fail
WCAG AAA:  Fail

Graphical Objects and User Interface Components

WCAG AA: - Fail

All my slides look like
this.
You can read this even if Contrast Ratio
you’re sitting in the back
of the room! 1 5 1 3, 1

Figure 2 Slide with higher contrast colors and bigger font passes the accessibility checker!

19.

20. The slide below presents many design problems that make it in less accessible for impaired
audiences.


https://webaim.org/resources/contrastchecker/?fcolor=0000FF&bcolor=FFFFFF

Problems here:

1 didn’t like how dark this shade
was so | tweaked i

e The lines of text in the list do not have enough white
space around them;

e The list items need to be numbered because they’re

b Smecsedeiins gl i providing sequentially ordered directions;

» n enim justo, rhoncus ut, . .

" mperir o, enanag s, 5 e The fontis not dark enough and there’s too much of it

» Hullam dictug feli
on one slide; and

e Its graphical elements are distracting and offer little to
the slide’s understanding overall — delete them!

21. Better design: Larger and darker text, less text on a single slide. Included more white space around
the text, numbered list items, delete graphical elements that distract from the slide’s information
overall and offered nothing else, otherwise.

I made this shade darker to
increase its readability

Directions - how to get to my house:

1. Donec quam felis,
2. ultricies nec, pellentesque eu, pretium quis, sem,

3. Nulla consequat massa quis enim,

22. Below is another slide with a number of issues: the table has no header rows, its font is too small
and not dark enough, and it contains both merged and blank cells. The lines of text next to the table
do not have enough white space around them, and the link’s URL is too long to be read by a screen
reader. Additionally, the slide itself is not titled.

Errors

4 Table has no header row
Table & (Slide 4)

4 Missing slide title
Slide 2
Slide 4

> 1wanted to hide my slide title and have lines and
lines of text like this

b 1wanted to hide my slide title and have lines and
lines of text like this.

» 1 wanted to hide my slide title and have lines and
lines of text like this

P | wanted to hide my slide title and have tines and
lines of text like this.

» | wanted to hide my slide title and heve lines and
lines af text like this Fra

Warnings

> 1also wani

Bttps:/ /vr

B

annoyingly long u
goosle. com zeard

[+ Hard-to-read text contrast (8)

4 Table has merged or split cells
Table 6 - 1 Cell (Slide 4)
I» Check reading order (2)

23. First, regarding tables, refrain from merging cells and or leaving cells or rows blank in a table. Enter
the word Null if a cell is blank or delete the row in its entirety if it's empty. Use a preformatted table
design to create contrast and readability of your table. On the Home ribbon - Table Tools Group
and click on the Design Tab.
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25.

26.

Table Tools

Make sure the table in your slide is still selected. In the Table Tools ribbon above, pick a Table Style
that has a high-contrast look to it. Tick Table Headers and First Column as well. This will allow a
screen reader to tab through the table in a sequential and logical order.

Header Row First Column P ——
[ ] Total Row [ Last Column B
[l Banded Rows [] Banded Calumns

With respect to the slide’s (links or URLs), you will need to employ two different URL treatments to
make the slide more screen reader friendly. First, use meaningful text in place of non-specific text
like “click here.” Second, avoid the insertion of long URLs in any document by using a site like tiny
url. For the first treatment, highlight the long URL, right click and copy it then delete (or just do a
cut). Next, insert your cursor in its place and mouse up to the hyperlink insertion button.
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Click it to prompt this pop-up window to open.

Textto display: side ttle In the Text to display field, write specific and meaningful information ie “Go to
Look in: Power Pt, Assistance specified article on Google Scholar.” And below, in the address field, isnert the
corenp | & Accessobie Templarg long URL like this:

Foiger |8 Deanng s pttps://www.sciencedirect.com/science/article/pii/S0169755298000877

%] Poorly Designed Ppt|
&| Ppt. Table styles

¥ Teach a Course Tem

EBrowsed
Pages

Recent
Files

Address: |

If your document will be read from a print out (some students may print your document), you also

need to include the text for the url so that it can be transcribed into a browser’s search window. Use
a site like tinyurl.com to generate a smaller URL, like this: https://tinyurl.com/3kuutvm6. You do not
need to create an account, just copy and paste in the link’s url, and the site will generate a short URL

you can then insert into any document.

GD Your Long URL

/" TinyuRL

https://tinyurl.com/3kuutvme

Title your slides so that users can easily navigate through an outline view to the section of your
presentation that is important to them. Go to View tab - Outline View - click in the space right
next to slide icons where no title is indicated next to them. Put your cursor next to those two


https://tinyurl.com/3kuutvm6

numbers, click to activate, and write in a slide title. If you want to hide the title of that slide, click
Home Tab - Arrange -> Selection Pane. Now in the Accessibility Inspection Report, click on the
Error Slide to open a pop-up window next to it, click Title # and turn off the eye icon.
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27. One of the last issues you need to check with your presentation is slide reading order. The error
presents in the Inspection Report like this:

4 Check reading order
Slide 4
Slide 5

To check reading order click on the Slide # to prompt a pop-up window to open next to it. With
PowerPoint slides, screen readers read from this list in order of bottom to top. So move you slide
title down to the bottom of the list, then Content holder, and then the Table (or change the order of
the text and graphic blocks on your slide so that a reading from the bottom up is logically sequential.
Simply click drag the items up or down to rearrange in their stacking order. In this case, | want the
title to read first, then the content, then the table, and then the title or header text.

Selection

Show All || Hide All
Table &
Content Placeholder 3
Title 7

28. Not all problems with a PowerPoint presentation can be detected with the Accessiblity Checker.
Look through your presentation again. Does it have good contrast? Are all fonts big enough and the
lines of text spaced appropriately? Are your lists numbered or bulleted correctly using the list
feature in the Paragraph Panel? Are all of your slides titled? Finally, be patient and generous in
respoinding to accessibility requests from students. Once you practice these design
accommodations, they are fast and easy to implement every time.



